Programfarm

Programfarm med Windows

Om hvordan du bruker programvare via fjernprogramløsningen "Programfarm" med Windows. Med Programfarm trenger du ikke å ha programvaren installert på din egen maskin.

English version: Software Farm with Windows

Ser du etter noe annet? Temasider om Programvare for studenter eller for ansatte | sider merket med Programfarm.

Tilkobling til Programfarm med Windows #

Fra Windows er det tre måter å få tilgang til NTNUs programfarm på:

1. Bruke en nettleser som Firefox eller Internet Explorer.

2. Lage snarveier i startmenyen på din lokale PC.

3. Åpning av programfarmen som et eksternt skrivebord (remote desktop)

Hvilken av disse metodene som er enklest og best er et spørsmål om smak og behag.

Alternativ 1. Programfarm via nettleseren #

  • Vi bruker nettleseren Firefox som eksempel.
  • Hvis du bruker Internet Explorer på en NTNU-jobbmaskin ("administrert klient") er det omtrent likedan. Forskjellene blir kommentert underveis.
  • Bruk av Microsoft Edge i Windows 10 er meget enkelt, se nedenfor.
  • Vi har en egen brukerveiledning for Internet Explorer på en privat maskin. Det er fordi du i såfall blir utsatt for en del sikkerhetsspørsmål som det ikke er rimelig å forlange at en vanlig bruker skal orke å forholde seg til. Hvis du skal bruke Programfarmens web-grensesnitt fra en privat maskin, er det enklere å bruke en annen webleser enn Internet Explorer.

Steg 1: Åpne farm.ntnu.no i webleseren

Skriv farm.ntnu.no i adressefeltet. Da kommer du til Programfarmens innloggingsbilde.

Legg gjerne siden til i "Favoritter" (Internet Explorer) eller "Bokmerker" (Firefox), eller som et bokmerke på Min side i Innsida.


Steg 2: Logg inn

Her fyller du ut ditt brukernavn og passord på win-ntnu-no, og trykker "Logg inn".

Da kommer du til siden med oversikten over alle programmer som er tilgjengelige på Programfarmen.

Når du kjører et program fra denne websiden, vil det oppføre seg som om du kjørte det fra din egen PC. De skriverne som er tilgjengelig på din egen PC, blir viderekoblet og er tilgjengelig i programmene.  Mappen «Dokumenter» er koblet opp mot hjemmeområdet ditt på NTNUs nett (normalt disk M:), og for ansatte evt. andre nettverksdisker du bruker i jobbsammenheng (f.eks. disk K:).  Disken på din lokale PC er også tilgjengelig, og det er mulig å klippe og lime mellom fjernsesjonen og din lokale PC.  Se  «Bruk av programfarmen», nedenfor.

Steg 3: Starte et program

Klikk på et programikon for å starte det. I eksemplet trykker vi på "Word 2013".

a) Første gang du åpner et program fra denne websiden vil nettleseren spørre hva du vil at den skal gjøre med "rdp-filer". Internet Explorer vet hva den skal gjøre her, så bruker du denne, får du ikke dette spørsmålet.

Vi velger "Tilkobling til eksternt skrivebord" fra rullefeltet. ("Remote Desktop Connection" hvis din PC har engelsk Windows.) Kryss av for "Gjør dette automatisk fra nå av", og trykk OK.

 

Som vi ser av dialogboksen, er dette en innstilling som også kan gjøres i Firefox fra menyen Verktøy->Brukervalg->Programmer (Tools->Options->Applications).

Hvis "Tilkobling til eksternt skrivebord" ikke vises i rullemenyen. 

b) Prosessen er i gang. Vi har altså trykket på "Word 2013", og det kommer opp en beskjed om at prosessen er i gang:

c) Første gang du starter et program fra websiden, får du et spørsmål om å godkjenne sertifikat. Hak av for "Ikke spør meg igjen om eksterne tilkoblinger fra denne utgiveren". Trykk på "Koble til".

I Internet Explorer vil dette spørsmålet se litt anderledes ut. Bl.a. vises ikke avkryssingsboksen for "Ikke spør meg igjen....". Se  "Bruk av Internet Explorer på en privat PC".

Ved å trykke på «Detaljer» vil du se at fjernkjøringssesjonen gir deg tilgang til din lokale disk, dine lokale printere og til din lokale klipp-og-lim-funksjon.

d) Passord nok en gang (Gjelder ikke Internet Explorer)

For det første programmet du starter etter at du er innlogget, vil du bli spurt om brukernavn og passord nok en gang:

e) Programmet kjører

Det programmet vi har valgt, i eksemplet "Word 2013", er åpnet.

Ved å trykke på "Computer" og deretter på "Documents", får du åpnet dokumenter på hjemmeområdet ditt (disk M:). Vi ser at jeg tidligere har hatt oppe et dokument "desc03_b.docx" under "Documents" på hjemmeområdet. Se forøvrig Disker og lagring, nedenfor.

Vi ser også at fjernkjøringsprogrammet legger seg på oppgavelinja på din lokale PC, som om det var et lokalt kjørt program.

Bruk av Microsoft Edge i Windows 10

Edge er den absolutt enkleste webleseren å bruke mot farm.ntnu.no. Framgangsmåten er som under Firefox over, bortsett fra at du i enda mindre grad blir plaget med spørsmål underveis. Med ett eneste unntak:

Hver eneste gang du klikker på et program på Farmens webside, blir ei "rdp"-fil lasta ned, og du blir spurt om du vil åpne fila. Klikk på "Åpne" og programmet du har valgt, starter opp.

Vi har ikke funnet noen måte å få satt "Tilkobling til eksterne skrivebord" som standardhandling, slik at vi slipper dette spørsmålet hver  gang. En annen ulempe er at mappa "Nedlastinger" etterhvert blir fylt opp av nedlastede rdp-filer.

Alternativ 2. Snarvei i startmenyen på din lokale PC #

Dette er et alternativ til å bruke webleseren:

Du kan installere snarveier til programmene på Farmen i startmenyen på PCen din. Slik blir de tilgjengelige nesten nøyaktig som om de var installert på din egen PC. Framgangsmåten er enkel, men oversikten over hvilke programmer du har tilgjengelig blir nok en del bedre ved å bruke websiden.

  • Gå til Start -> Kontrollpanel
  • Her finner du "Tilkoblinger til RemoteApp og skrivebord", som du åpner.
  • Hvis du ikke finner den, kan du bruke søkefeltet og søke på "remote"

Programfarm_Windows18

  • Velg "Konfigurer ny tilkobling med Tilkoblinger til RemoteApp og skrivebord".
  • Skriv inn url-adressen
    https://farm.ntnu.no/RDweb/Feed/webfeed.aspx
    og trykk Neste.

Programfarm_Windows21

Du vil da måtte gå igjennom følgende prosess:

1. Klar til å etablere forbindelsen

2. Oppgi brukernavn og passord:

3. Suksess!

Du kan nå gå til Start->Alle programmer -> Tilkoblinger til RemoteApp og skrivebord->NTNU Programfarm:

Programfarm_Windows20

Det er ei svært lang liste over tilgjengelige programmer. Så det raskeste er kanskje å bruke "Søk i programmer og filer".

Hvis du har Windows 10 på din PC, trykk på Start->Alle apper->NTNU Programfarm, og du ser farmens programmer slik:

Oppdatere listen over RemoteApps manuelt #

Denne lista skal som standard oppdateres automatisk en gang i døgnet og ved hver pålogging. Hvis du likevel har behov for å oppdatere lista over RemoteApps manuelt kan du gjøre det slik: 

  • Gå til Start –> Kontrollpanel og søk etter remote.
  • Velg "Tilkoblinger til RemoteApp og skrivebord".

Du vil da få opp dette vinduet. Trykk på Egenskaper. I det nye vinduet man da får opp, trykker man på knappen "Oppdater nå".

Alternativ 3. Programfarm via tilkobling til eksternt skrivebord #

Vi har nå gjennomgått 2 tilkoblingsalternativer til Farmen.

(1) Bruk av nettleser

(2) Snarveier til Programfarmens programmer i din egen startmeny

Det tredje alternativet er å koble seg til Programfarmens egne skrivebord:

(3) Denne gang finner vi tilkoblingsprogrammet i startmenyen:

Start -> Tilkobling til eksternt skrivebord

Adminfarm, officefarm, edgefarm, calcfarm, devfarm, legacyfarm, kavlifarm og ielfarm #

Programfarmen har fem forskjellige skrivebord:

Eksternt skrivebordHvem det skal brukes av
adminfarm.ntnu.noNTNU-ansatte. Ikke ansatte ved randsonebedrifter.
officefarm.ntnu.noStudenter. Også tilgjengelig for NTNU-ansatte med studentkonto.
edgefarm.it.ntnu.noRandsonebedrifter som f.eks. Uninett.
calcfarm.ntnu.noStudenter og ansatte som har bruk for vitenskapelig programvare
samt programvare for matematikk og statistikk.
devfarm.ntnu.noStudenter og ansatte som har bruk for utviklerprogramvare som f.eks. Visual Studio
legacyfarm.ntnu.noAdministrativt ansatte som har bruk for de foreldede grensesnittene som
NTNUs regnskapsprogrammer krever: eldgammel Internet Explorer og eldgammel Java.
kavlifarm.it.ntnu.noKavliinstitutt for nevrovitenskap
ielfarm.it.ntnu.noInstitutt for elkraftteknikk

adminfarm, officefarmog edgefarm finner du alle Office-programmene og et rikholdig utvalg av andre kontorverktøy mm.

Calcfarm inneholder diverse matematikk- og statistikkprogrammer. Den kan brukes av både studenter og ansatte.

(Kjennetegnene for disse forskjellige programfarmene vises under programikonet i Farmens web-grensesnitt (Alternativ 1 over), som hhv. [A], [O], [E], [C], [D], [L], [K] og [IEL]. Men det er likevel helt uten betydning for brukeren av web-grensesnittet.)

Etter at vi har klikket på "Tilkobling til eksternt skrivebord" i Startmenyen, får vi opp dette bildet, hvor vi skriver inn den farmen vi ønsker å koble oss til, og trykker "Koble til".

(Se nedenfor om "Konfigurasjonsdetaljer" for hva som skjuler seg bak knappen "Alternativer" nederst til venstre i dialogboksen.)

Første gang du kobler deg til Farmen på denne måten, vil du bli spurt om å godkjenne forbindelsen. Kryss av for "Ikke spør meg på nytt...." og trykk "Koble til".

Du blir deretter spurt om brukernavn og passord.

Hvis du sitter på en privat PC hvor du er innlogget med et lokalt brukernavn, kan det være nødvendig å trykke på "Bruk en annen konto", slik at du får logget deg på med NTNU-kontoen din. Da må du også bruke "win-ntnu-no\<brukernavn>", slik:

Trykk "OK", og tilkoblingen utføres med ventebilde:

Den eksterne maskinas skrivebord åpner seg som om du ikke lenger er på din egen PC, men på en annen maskin, men f.eks. på "officefarm.ntnu.no":

Ved å klikke på det hvite vindus-symbolet nederst til venstre, får vi opp en mer informativ skjerm, startskjermen. Startskjermen erstatter den startmenyen du er vant til.

Ved å klikke på sirkelen med ei pil i, nederst til venstre, får vi opp en oversikt over programmene. Det er som å åpne "Alle programmer" i den startmenyen du er vant til.

Programmene du starter, kjører på det eksterne skrivebordet. De blir ikke synlige på din lokale PCs oppgavelinje, men på det eksterne skrivebordets. Brukerprofilen, som bli lastet inn på PCen din hver gang du logger på med NTNU-brukernavn og -passord, blir lastet inn også her. Den inneholder opplysninger om hjemmeområdet og eventuelle andre nettverksdisker knyttet til jobben din. Men av uforståelige grunner, intet om skrivere.

For mer om dette, se Brukergrensesnitt i Programfarmen.

Konfigurasjonsdetaljer for eksternt skrivebord #

(Ved bruk av alternativ 1 (bruk av webleser) og alternativ 2 (snarveier på startmenyen), har vi sørget for at disse tingene skjer automatisk.)

Serveren har dessverre Windows 8 sitt touch screen-orienterte, mus- og tastaturfiendtlige grensesnitt. (Se Brukergrensesnitt i Programfarmen. Heldigvis har Windows 10 gjeninnført en del ting vi savner i Win 8, f.eks. startmenyen.) For ikke å miste orienteringsevnen, er det best å gjøre de velkjente windowstastene tilgjengelige i det eksterne skrivebordet. Det gjør du i konfigurasjonspanelet til programmet "Tilkobling til eksternt skrivebord" på din PC: Trykk på "Vis alternativer" og velg fanen "Lokale ressurser".

Her velger du "På den eksterne datamaskinen" for Tastatur.

Det er også lurt å hake av for "Skrivere" og "Utklippstavle" under "Lokale enheter og ressurser". Da blir de skriverne du har tilgjengelig på din egen PC viderekoblet til det eksterne skrivebordet, og klipp-og-lim-funksjonen blir felles for den lokale og den eksterne maskinen.

Ved å trykke på "Mer" under "Lokale enheter ..." , kan du velge andre lokale ressurser som skal viderekoples til det eksterne skrivebordet. Det eksterne skriverbordet blir aktivert med din egen brukerprofil, slik at nettverksdisken din ("M:") og andre disker som ligger i profilen, blir tilgjengelig uansett. Men det kan være greit at lokal disk C:\ viderekobles.

Under fanen "Skjerm" kan du velge skjermstørrelse for det eksterne skrivebordet.

Hvis du setter slideren på maks, vil det eksterne skrivebordet vises i fullskjerm, og altså dekke hele skjermen på din lokale PC. 

Kryss av for "Vis tilkoblingslinjen når jeg bruker full skjerm". Da får du en liten verktøylinje øverst, som lar deg justere dette når du først er pålogget. Det er jo kjekkest å ha det eksterne skrivebordet i et vindu på det lokale skrivebordet, slik at du lett kan bytte mellom Farmen og din egen PC.

I fanen "Opplevelse", kan du sette tilkoblingshastigheten til det du har tilgjengelig. Når for tida har jo de fleste ganske god bredbåndsforbindelse, så det er det ingen grunn til å la denne innstillingen stå på mindre enn max: "LAN". Å velge et langsommere alternativ gjør at mindre av båndbredden blir brukt på grafikkvalitet.

Bruk av Programvarefarm #

Om brukergrensesnittet på det eksterne skrivebordet #

Skrivebordet på Programvarefarmen kan være ukjent for de fleste, da det er hentet fra Windows 8. Her får du vite mer om Brukergrensesnitt i Programfarmen.

Utklippstavlen #

Du kan klippe og lime mellom programmer som kjører i fjernsesjonen og de som kjører lokalt på din egen PC.

Disker og lagring #

Når du trykker på Lagre inne i et åpnet program, får du opp "Dokumenter" fra hjemmeområdet ditt. Det er altså "Dokumenter" fra nettverksdisken din som du nå lagrer til ("M:\Dokumenter").

  • Ved å velge lagre som og deretter  datamaskin, ser du alle disker som er tilgjengelig i fjernsesjonen.
  • I figuren under er Nettverksplasseringer serverens oppkobling av mine nettverksdisker ut fra brukerprofilen min.
  • "Enheter og stasjoner" er lokale disker tilkoblet min lokale PC og som er viderekoblet derfra.  Hvis du er koblet opp mot hjemmeområdet på din lokale PC, vil dette vises to steder: som hentet fra profilen og som viderekoblet.
  • Den som er svært nysgjerrig, vil også finne diskene på sin lokale PC under Nettverk->tsclient, i venstre sidestolpe.

Utskrift #

Eksemplet nedenfor viser utskriftsmenyen i Word 2013 på Programfarmen.

  • Skrivere som er tilkoblet lokalt på din lokale PC er tilgjengelige. De er merket med redirected (se 2 i figuren).
  • Skrivere som er standard i farmen, eller som du selv har lagt til i farmen (se nedenfor), er ikke merket med redirected (se 1 i figuren)

Det er ikke mulig å benytte de menypunktene i hvert enkelt program som tilbyr deg å legge til skriver: 3 i figuren under virker altså ikke. Dette er standard på NTNUs nett. Grunnen til det, er at NTNUs skrivere ligger på et eget nett bak en sikkerhetsmur pga. tidligere misbruk fra eksterne hackere.

Å legge til skrivere #

Skrivere installeres fra "Enheter og skrivere" i kontrollpanelet på Farmen. Her kan man også se hvilke skrivere som er tilgjengelige. Hvordan man får åpnet Kontrollpanel->Enheter og skrivere, er forskjellig avhengig av hvilket tilkoblingsalternativ du har valgt.

Alternativ 1: Via webleseren

Her finner du "Enheter og skrivere" i mappen Geek!

Alternativ 2: Snarveier i startmenyen

Her finner du "Enheter og skrivere" under navnet "Skrivere", ved å trykke på startmenyen:

Start->Alle programmer -> Tilkoblinger til RemoteApp og skrivebord->NTNU Programfarm.

Scroll nedover til du finner "Skrivere" eller "Printers".

Alternativ 3: Som eksternt skrivebord

Her finner du flisa for "Kontrollpanel" i Startskjermen. Derfra åpner du "Enheter og skrivere".

Vi har fått åpnet "Enheter og skrivere" uansett tilkoblingsmetode.

De skriverne som er satt opp på din lokale PC blir viderekoblet til Farmens skrivebord og er tilgjengelige derfra. De er merket med redirected. Her er f.eks. "ntnu-it-felles" viderekoblet fra PCen min. Mens "ntnuprint-ricoh" er standardskriver for ansatte på Farmen.

I oppgavelinjen øverst i "Enheter og skrivere" trykker vi på "Legg til en skriver" (se figuren over).  Da kommer det opp et dialogvindu hvor det står "Finner ingen skrivere".  Nederst i vinduet står det "Skriveren jeg vil ha, er ikke listet".  Trykk på det.

Vi kommer da til et skjermbilde "Søk etter en skriver på andre måter". I feltet "Velg en delt skriver, etter navn", fyll ut med "\\followprint.win.ntnu.no\".   Det er viktig med den avsluttende bakoverskråstreken.  Du får da opp ei liste med tilgjengelige skrivere som du kan velge fra.

Velg skriver, og trykk "Neste". Du må nå igjennom etpar dialogvinduer som er relativt selvforklarende. Og etter det vises din valgte skriver i Kontrollpanel->Enheter og skrivere, og er tilgjengelig i de programmene du bruker.

Skrivervalget lagres i din lokale profil på Programfarmen, og er dermed tilgjengelig for framtidig bruk.

Hvis du er logget på Programfarmens egne skrivebord (alternativ 3), kan det likevel se ut som om skriveren lagres kun for den farmen du er pålogget da du foretok skrivervalget. Altså at skrivervalg for adminfarm ikke blir lagret for officefarm.

Appendix: Hvis «Tilkobling til eksternt skrivebord» ikke vises i rullefeltet #

Dette gjelder bruk av Firefox o.l. under alternativ 1, bruk av webleser, ovenfor. Dette gjelder ikke Internet Explorer.

Noen har opplevd at «Tilkobling til eksternt skrivebord»/«Remote Desktop Connection» ikke vises i rullefeltet for «Åpne med». Da vil man isteden finne «Bla gjennom».

Kryss av for «Gjør dette automatisk fra nå av» før du velger «Åpne med» og trykker på «Bla gjennom».

Du får opp ei liste med mulige programmer, men det du søker står ikke der. Derfor må du velge «Velg», slik at du får opp en filbehandler, som du kan bla deg fram i.


På Windows 7 blar man til C:\windows\system32\mstsc.exe, slik:

med en privat PC,

Du kan bruke dette i en 64-bits Windows også. Men her fins det i tillegg en 64-bits versjon av programmet, som ligger på

C:\windows\sysWOW64\mstsc.exe

Kontakt #

Orakeltjenesten kan hjelpe deg hvis du støter på problemer. Ansatte bes om å kontakte lokal IT-ansvarlig.

67 Vedlegg
35022 Visninger
Gjennomsnitt (3 Stemmer)